// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]))|((([a-zA-Z]|[a-zA-Z][a-zA-Z0-9\-]*[a-zA-Z0-9])\.)+([A-Za-z|[A-Za-z][A-Za-z0-9\-]*[A-Za-z0-9])))$").unwrap();
let string = "foo
foo.bar
www.foo.bar
.foo
foo.
foo.com.
.com.bar
foo-bar.com
foo-bar.com-eu
foo.bar.com
0.foo.bar
foo.1.bar
foo.bar.2
.1.bar.com
foo.bar1.com
foo.2bar.com
foo.bar3.com
foo.bar.4com
127
127.0
127.0.0
127.0.0.1
.127
.127.0
.127.0.0
.127.0.0.1
8.8.8.8
8.8.4.4
c:/
c:/foo/
c:/foo/bar/
\\\\
\\\\foo
\\\\foo.bar
\\\\foo\\bar
http://regexp101.com
regexp101.com
www.regexp101.com
www.regexp101.com/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}