using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]))|((([a-zA-Z]|[a-zA-Z][a-zA-Z0-9\-]*[a-zA-Z0-9])\.)+([A-Za-z|[A-Za-z][A-Za-z0-9\-]*[A-Za-z0-9])))$";
string input = @"foo
foo.bar
www.foo.bar
.foo
foo.
foo.com.
.com.bar
foo-bar.com
foo-bar.com-eu
foo.bar.com
0.foo.bar
foo.1.bar
foo.bar.2
.1.bar.com
foo.bar1.com
foo.2bar.com
foo.bar3.com
foo.bar.4com
127
127.0
127.0.0
127.0.0.1
.127
.127.0
.127.0.0
.127.0.0.1
8.8.8.8
8.8.4.4
c:/
c:/foo/
c:/foo/bar/
\\
\\foo
\\foo.bar
\\foo\bar
http://regexp101.com
regexp101.com
www.regexp101.com
www.regexp101.com/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}