import Foundation
let pattern = #"^(((([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]))|((([a-zA-Z]|[a-zA-Z][a-zA-Z0-9\-]*[a-zA-Z0-9])\.)+([A-Za-z|[A-Za-z][A-Za-z0-9\-]*[A-Za-z0-9])))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo
foo.bar
www.foo.bar
.foo
foo.
foo.com.
.com.bar
foo-bar.com
foo-bar.com-eu
foo.bar.com
0.foo.bar
foo.1.bar
foo.bar.2
.1.bar.com
foo.bar1.com
foo.2bar.com
foo.bar3.com
foo.bar.4com
127
127.0
127.0.0
127.0.0.1
.127
.127.0
.127.0.0
.127.0.0.1
8.8.8.8
8.8.4.4
c:/
c:/foo/
c:/foo/bar/
\\
\\foo
\\foo.bar
\\foo\bar
http://regexp101.com
regexp101.com
www.regexp101.com
www.regexp101.com/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)