#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w*:)\s?(.*)\s?(\d{1,2}-\d{1,2})\s?(.*)"
Local $sString = "Football: Real Madrid 2-1 FC Barcelona" & @CRLF & _
"Football: Atletico de Madrid 4-2 Real Madrid" & @CRLF & _
"Football: Hannover 96 3-3 1.FC Nuernberg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")