const regex = /(\w*:)\s?(.*)\s?(\d{1,2}-\d{1,2})\s?(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w*:)\\s?(.*)\\s?(\\d{1,2}-\\d{1,2})\\s?(.*)', 'gm')
const str = `Football: Real Madrid 2-1 FC Barcelona
Football: Atletico de Madrid 4-2 Real Madrid
Football: Hannover 96 3-3 1.FC Nuernberg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}