import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w*:)\\s?(.*)\\s?(\\d{1,2}-\\d{1,2})\\s?(.*)";
final String string = "Football: Real Madrid 2-1 FC Barcelona\n"
+ "Football: Atletico de Madrid 4-2 Real Madrid\n"
+ "Football: Hannover 96 3-3 1.FC Nuernberg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}