$re = '/(\w*:)\s?(.*)\s?(\d{1,2}-\d{1,2})\s?(.*)/m';
$str = 'Football: Real Madrid 2-1 FC Barcelona
Football: Atletico de Madrid 4-2 Real Madrid
Football: Hannover 96 3-3 1.FC Nuernberg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);