import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:БУМАГ(?:А|И)?|ПЕЧАТЬ|ЛИСТОК) №\\s*(\\d+)";
final String string = "Nice module. How can I convert @username to mentions with user profile link and #hashtag into links site wide. Just like twitter. БУМАГА № 42 I am spfooecifically interested to use them in status updates (statuses). ПЕЧАТЬ № 335 There are mentions and hashtag modules, but БУМАГ №0000 they have some limitations. Mentions module requires БУМАГИ № 666 [@username] this bracket and hashtags do not work on ЛИСТОК №1 statuses.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}