const regex = /(?:БУМАГ(?:А|И)?|ПЕЧАТЬ|ЛИСТОК) №\s*(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:БУМАГ(?:А|И)?|ПЕЧАТЬ|ЛИСТОК) №\\s*(\\d+)', 'g')
const str = `Nice module. How can I convert @username to mentions with user profile link and #hashtag into links site wide. Just like twitter. БУМАГА № 42 I am spfooecifically interested to use them in status updates (statuses). ПЕЧАТЬ № 335 There are mentions and hashtag modules, but БУМАГ №0000 they have some limitations. Mentions module requires БУМАГИ № 666 [@username] this bracket and hashtags do not work on ЛИСТОК №1 statuses.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}