$re = '/(?:БУМАГ(?:А|И)?|ПЕЧАТЬ|ЛИСТОК) №\s*(\d+)/';
$str = 'Nice module. How can I convert @username to mentions with user profile link and #hashtag into links site wide. Just like twitter. БУМАГА № 42 I am spfooecifically interested to use them in status updates (statuses). ПЕЧАТЬ № 335 There are mentions and hashtag modules, but БУМАГ №0000 they have some limitations. Mentions module requires БУМАГИ № 666 [@username] this bracket and hashtags do not work on ЛИСТОК №1 statuses.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);