# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:БУМАГ(?:А|И)?|ПЕЧАТЬ|ЛИСТОК) №\s*(\d+)"
test_str = "Nice module. How can I convert @username to mentions with user profile link and #hashtag into links site wide. Just like twitter. БУМАГА № 42 I am spfooecifically interested to use them in status updates (statuses). ПЕЧАТЬ № 335 There are mentions and hashtag modules, but БУМАГ №0000 they have some limitations. Mentions module requires БУМАГИ № 666 [@username] this bracket and hashtags do not work on ЛИСТОК №1 statuses."
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.