#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?-i)(?<=[a-z]\s)[A-Z\d].*?\(\d+\)"
Local $sString = "A random string with movie titles in it. " & @CRLF & _
"Movies like The Thing (1984) and other titles like Captain America Civil War (2016). " & @CRLF & _
"The movies could be anywhere in this string. " & @CRLF & _
"And some movies like 28 Days Later (2002) could start with a number."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")