re = /(?-i)(?<=[a-z]\s)[A-Z\d].*?\(\d+\)/
str = 'A random string with movie titles in it.
Movies like The Thing (1984) and other titles like Captain America Civil War (2016).
The movies could be anywhere in this string.
And some movies like 28 Days Later (2002) could start with a number.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end