import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?-i)(?<=[a-z]\\s)[A-Z\\d].*?\\(\\d+\\)";
final String string = "A random string with movie titles in it. \n"
+ "Movies like The Thing (1984) and other titles like Captain America Civil War (2016). \n"
+ "The movies could be anywhere in this string. \n"
+ "And some movies like 28 Days Later (2002) could start with a number.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}