const regex = /(?-i)(?<=[a-z]\s)[A-Z\d].*?\(\d+\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?-i)(?<=[a-z]\\s)[A-Z\\d].*?\\(\\d+\\)', 'g')
const str = `A random string with movie titles in it.
Movies like The Thing (1984) and other titles like Captain America Civil War (2016).
The movies could be anywhere in this string.
And some movies like 28 Days Later (2002) could start with a number.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}