using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(1|2|3|4|5|6|,|-|\s|&|and|or){1,12}bedroom";
string input = @"you have a choice between 1, 2 or 3 bedrooms
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}