package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(1|2|3|4|5|6|,|-|\s|&|and|or){1,12}bedroom`)
var str = `you have a choice between 1, 2 or 3 bedrooms
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}