$re = '/(1|2|3|4|5|6|,|-|\s|&|and|or){1,12}bedroom/m';
$str = 'you have a choice between 1, 2 or 3 bedrooms
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);