// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(1|2|3|4|5|6|,|-|\s|&|and|or){1,12}bedroom").unwrap();
let string = "you have a choice between 1, 2 or 3 bedrooms
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}