#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+?)\s*\b(\d{5,7}\b.*)"
Local $sString = "1338516 -...pair - 5pk 1409093 -...re Wax 3Pk" & @CRLF & _
"1409085 -...dtnr - 5pk 1415090 -...accessories" & @CRLF & _
"490663 - 3 pack 1490739 -...2 - 3 pack"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")