import re
regex = re.compile(r"^(.+?)\s*\b(\d{5,7}\b.*)", flags=re.MULTILINE)
test_str = ("1338516 -...pair - 5pk 1409093 -...re Wax 3Pk\n"
"1409085 -...dtnr - 5pk 1415090 -...accessories\n"
"490663 - 3 pack 1490739 -...2 - 3 pack")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")