package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+?)\s*\b(\d{5,7}\b.*)`)
var str = `1338516 -...pair - 5pk 1409093 -...re Wax 3Pk
1409085 -...dtnr - 5pk 1415090 -...accessories
490663 - 3 pack 1490739 -...2 - 3 pack`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}