# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\D*(?<!\.)//gm;t' <<< "dfff $12.3
USD 44,555.00"