$re = '/\D*(?<!\.)/m';
$str = 'dfff $12.3
USD 44,555.00';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;