const regex = /\D*(?<!\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D*(?<!\\.)', 'gm')
const str = `dfff \$12.3
USD 44,555.00`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);