use strict;
my $str = 'dfff $12.3
USD 44,555.00';
my $regex = qr/\D*(?<!\.)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";