$re = '/Property [a-zA-Z0-9\\\\_\:\$\(\) &]+ does not accept PHPUnit\\\\Framework\\\\MockObject\\\\MockObject\./m';
$str = 'Property Tests\\Unit\\Libraries\\ImportInvoices\\Robots\\EfaturaRobotTest::$urlBuilderMock (App\\Libraries\\Utilities\\Builders\\UrlBuilder&PHPUnit\\Framework\\MockObject\\MockObject) does not accept PHPUnit\\Framework\\MockObject\\MockObject.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);