import Foundation
let pattern = #"Property [a-zA-Z0-9\\_\:\$\(\) &]+ does not accept PHPUnit\\Framework\\MockObject\\MockObject\."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Property Tests\Unit\Libraries\ImportInvoices\Robots\EfaturaRobotTest::$urlBuilderMock (App\Libraries\Utilities\Builders\UrlBuilder&PHPUnit\Framework\MockObject\MockObject) does not accept PHPUnit\Framework\MockObject\MockObject."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)