// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Property [a-zA-Z0-9\\_\:\$\(\) &]+ does not accept PHPUnit\\Framework\\MockObject\\MockObject\.").unwrap();
let string = "Property Tests\\Unit\\Libraries\\ImportInvoices\\Robots\\EfaturaRobotTest::$urlBuilderMock (App\\Libraries\\Utilities\\Builders\\UrlBuilder&PHPUnit\\Framework\\MockObject\\MockObject) does not accept PHPUnit\\Framework\\MockObject\\MockObject.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}