using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((feature|bugfix|hotfix)\/([a-zA-Z]{2,6}-\d{1,6}|NO-?JIRA)\-[a-zA-Z0-9-_]{1,30}|release\/\d+\.\d+\.?\d*)$";
string input = @"release/0.8
release/58.11
release/58.15.45
feature/VECTWO-1234-Something-Here
release/RC-0.8
release/58
feature/VECTWO-1234-Something-Really-Long-Too-Long-In-Fact";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}