import Foundation
let pattern = #"^((feature|bugfix|hotfix)\/([a-zA-Z]{2,6}-\d{1,6}|NO-?JIRA)\-[a-zA-Z0-9-_]{1,30}|release\/\d+\.\d+\.?\d*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
release/0.8
release/58.11
release/58.15.45
feature/VECTWO-1234-Something-Here
release/RC-0.8
release/58
feature/VECTWO-1234-Something-Really-Long-Too-Long-In-Fact
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)