#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!while\b|return\b)[A-Za-z0-9_]+"
Local $sString = "while" & @CRLF & _
"while1" & @CRLF & _
"return" & @CRLF & _
"return2" & @CRLF & _
"other words" & @CRLF & _
"I Ihope123" & @CRLF & _
"Lett3xs" & @CRLF & _
"" & @CRLF & _
"while234" & @CRLF & _
"" & @CRLF & _
"return_79as"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")