$re = '/\b(?!while\b|return\b)[A-Za-z0-9_]+/m';
$str = 'while
while1
return
return2
other words
I Ihope123
Lett3xs
while234
return_79as';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);