import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!while\\b|return\\b)[A-Za-z0-9_]+";
final String string = "while\n"
+ "while1\n"
+ "return\n"
+ "return2\n"
+ "other words\n"
+ "I Ihope123\n"
+ "Lett3xs\n\n"
+ "while234\n\n"
+ "return_79as";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}