re = /\b(?!while\b|return\b)[A-Za-z0-9_]+/m
str = 'while
while1
return
return2
other words
I Ihope123
Lett3xs
while234
return_79as'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end