import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<cometes>[\\'\\\"])(.*?)(?P=cometes)$";
final String string = "' \"pep = 12\" as'\n\n"
+ "' \"pep = 12\" '\n\n"
+ "test \"\" 'pep \"= 12' \"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}