using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(\S+)$";
string input = @"Комплект мебели Фея Досуг 201 Алфавит зеленый 5693-3
Комплект мебели Ника Веселая азбука NKP1/5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}