package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+(\S+)$`)
var str = `Комплект мебели Фея Досуг 201 Алфавит зеленый 5693-3
Комплект мебели Ника Веселая азбука NKP1/5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}