// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+(\S+)$").unwrap();
let string = "Комплект мебели Фея Досуг 201 Алфавит зеленый 5693-3
Комплект мебели Ника Веселая азбука NKP1/5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}