using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\s*(?:-\s*)?(.+)";
string input = @"Стать авантюристом! ~ Как пройти подземелье с помощью панели навыков ~ 3 - 15
Я получил читерскую способность и был перенесен в иной мир, так что теперь я буду жить, как сам того захочу 2 Экстра";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}