$re = '@\d+\s*(?:-\s*)?(.+)@m';
$str = 'Стать авантюристом! ~ Как пройти подземелье с помощью панели навыков ~ 3 - 15
Я получил читерскую способность и был перенесен в и ной мир, так что теперь я буду жить, как сам того захочу 2 Экстра';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);