re = /\d+\s*(?:-\s*)?(.+)/m
str = 'Стать авантюристом! ~ Как пройти подземелье с помощью панели навыков ~ 3 - 15
Я получил читерскую способность и был перенесен в иной мир, так что теперь я буду жить, как сам того захочу 2 Экстра'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end