import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\s*(?:-\\s*)?(.+)";
final String string = "Стать авантюристом! ~ Как пройти подземелье с помощью панели навыков ~ 3 - 15\n\n\n"
+ "Я получил читерскую способность и был перенесен в иной мир, так что теперь я буду жить, как сам того захочу 2 Экстра";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}