using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:sunday|monday|tuesday|wednesday|thursday|friday|saturday)(\d+)";
string input = @"monday12monday, tuesday567tuesday, friday87friday";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}