$re = '/(?:sunday|monday|tuesday|wednesday|thursday|friday|saturday)(\d+)/';
$str = 'monday12monday, tuesday567tuesday, friday87friday';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);