// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:sunday|monday|tuesday|wednesday|thursday|friday|saturday)(\d+)").unwrap();
let string = "monday12monday, tuesday567tuesday, friday87friday";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}