package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:sunday|monday|tuesday|wednesday|thursday|friday|saturday)(\d+)`)
var str = `monday12monday, tuesday567tuesday, friday87friday`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}