#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.{2,8}$)(.*)"
Local $sString = "Pass:" & @CRLF & _
"" & @CRLF & _
"Aa1" & @CRLF & _
"Bbcdd123" & @CRLF & _
"Cc3" & @CRLF & _
"" & @CRLF & _
"Fail:" & @CRLF & _
"" & @CRLF & _
"abc" & @CRLF & _
"Bbbccdd123Bbbccdd123" & @CRLF & _
"123" & @CRLF & _
"aB2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")