import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.{2,8}$)(.*)";
final String string = "Pass:\n\n"
+ "Aa1\n"
+ "Bbcdd123\n"
+ "Cc3\n\n"
+ "Fail:\n\n"
+ "abc\n"
+ "Bbbccdd123Bbbccdd123\n"
+ "123\n"
+ "aB2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}