$re = '/^(?=[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.{2,8}$)(.*)/m';
$str = 'Pass:
Aa1
Bbcdd123
Cc3
Fail:
abc
Bbbccdd123Bbbccdd123
123
aB2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);